Alesis QX Series MIDI Controllers - Controller Mapping in Logic Pro

alesis qx49 main2This guide provides a walk through on how to map the knobs, sliders, and transport controls on Alesis QX series MIDI controllers to controls in Apple's Logic Pro software. This applies to the QX25, QX49, and QX61 controllers.  It also covers saving and loading a template of the mapping you create.

 

Contents

 

Assigning Transport Controls in Logic Pro
  1. Connect the QX49 to a USB port on your computer and launch Logic Pro. Create a new project. Add 8 or more tracks (to accommodate slider mapping later on).
  2. Select Logic Pro > Preferences > Key Commands.
     
  3. At the left of the window that opens, under Command, click the arrow next to Global.
     
  4. In the list that appears, click Record.
     
  5. At the bottom-right of the window, click Learn New Assignment.
     
  6. Press the Record button on the Alesis QX49. The button on the QX49 will now trigger the Record function in the Logic Pro transport window.
     
  7. Repeat steps 3-5 with other transport controls you’d like to assign. To assign sliders and knobs, proceed to the steps below.

 

Assigning Sliders and Knobs in Logic Pro
  1. Select Window > Mixer (CMD+2) to open the Mixer window.
     
  2. In Logic, select Logic Pro > Preferences > Control Surfaces > Learn Assignment (CMD+L) to open the Controller Assignments window.
     
  3. To map your first control, click and drag the volume slider in the first channel in Logic’s Mixer window.

    The Controller Assignments window will register that you are assigning a control to this first volume slider, and will begin listening for MIDI input from any connected controllers.
     
  4. Now move a knob or slider on your Alesis controller to associate it with the volume slider on the screen.

    The Controller Assignments window will list that the Volume control on the first channel in your mixer has been Learned.
     
  5. Next, click and drag the volume slider in the second channel in the Logic Mixer window.
     
  6. Move a different knob or slider on your Alesis controller to associate it with the volume slider on the screen.
     
  7. The Controller Assignments window will list that the Volume control on the second channel in your has been Learned.
     
  8. Repeat the above steps with any knobs or sliders on the Logic Mixer you’d like to map to your Alesis controller.
     
  9. If you make a mistake, you can click any entry in the Control column in the Controller Assignments and press the Delete key on your computer keyboard to remove the assignment.
     
  10. When you are finished, close the Controller Assignments window. The knobs and sliders you mapped in the steps above should now respond to movements on your Alesis controller.

 

Saving a Template
  1. Select the File menu at the top of the screen and choose Save as Template.

    File > Save as Template…
     
  2. In the window that opens, name your new template, and click Save.

    You’ll likely create many of your own templates as your recording work flow develops, grows, and changes over time.

 

Use your saved template when creating new projects in the future
  1. The next time you want to start a new project in Logic, select the File menu at the top of the screen and choose New (CMD+N).

    File > New (CMD+N)
     
  2. In the left-hand side of the window that opens, select My Templates.

    Then, on the right-hand side of the window, click the template you saved earlier.

 

 

 

Technical Support and Warranty Service

Whether you are a customer or dealer, if you already own a Alesis product, or if you just have pre-sales questions, the Alesis technical support team is available to help!

Each product has a dedicated support page on the website where you can find manuals, specifications, software updates, drivers and troubleshooting guides: www.alesis.com

Visit the link below to connect with any of the following support options: online community support, phone support, email support.